Samsung Galaxy S4 — Reparacion Wifi S4 instalando modem en Android 4.3

  • Respuestas:395
  • AbiertoMarcado con chinchetaSin solución
  • Posts del Foro: 1

11-mar-2015 0:13:27 vía Web

hola a todos, yo poseo un s4 i9500, lo actualize en el mes de diciembre a 4.4.2 con una rom stock, dia despues de la actualizacion del sistema el wifi no quiso activarse mas hace el inteto pero no termina de activar. al telefono lo e ruteado varias veces, la rom original se la e cambiado varias veces por diferente rom que son compatibles con mi telefono, le e borrado la carpeta efs (esa carpeta es delicada ya que guarda el emei del telefono sin ella el telefono queda como pisa papel) y la e reustarado y nada pero nada me a servido, la ultima esperanza era cuando saliera la version lollipop (5.0.1) , pero no se soluciono, no se activa el wifi. SI ALGUIEN SABE DE ALGUNA SOLUCION POR FAVOR COMPARTALA.

  • Posts del Foro: 1

11-mar-2015 2:00:43 vía Web

"Giancarlo Crespo funciono par mi sin instalar nada ; despues de probar todo:
1->>S4 con root >> 2->>instalar root explorer >> 3->>con root explorer abrir "system/build.prop" con el editor de texto) 4->buscar la linea: ro.securestorage.support=true cambiarla por: ro.securestorage.support=false
5 guarden 6 reinicien el celular
i9505 4.4.2 kitkat wifi solucionado!!

A mi me funciono!"

Hola, qué es S4 con root? cómo hago eso?. Sorry, no entiendo nada de estos temas pero quiero arreglar mi Wifi :/

— modificado el 11-mar-2015 2:05:03

  • Posts del Foro: 1

24-mar-2015 9:42:19 vía Web

Hola tengo este mismo problema pero en el Samsung sgh-i337 de atnt usa.no agarra el WiFi se queda muerto como en gris y no responde tampoco el blutuo funciona mi versión en 4.4.2 KitKat alguien que me pueda asesorar q a ser gracias ....

  • Posts del Foro: 1

22-abr-2015 18:15:23 vía Web

Hola la version de mi android es 4.4.2 quiero saber como hago para localizar el link para poder arreglar el wifi de mi s4
quedo atenta gracias!

  • Posts del Foro: 2.492

26-abr-2015 15:13:45 vía App

Hola a todos los que siguen teniendo problemas con el wifi de su S4.
En principio los fix publicados al inicio del post son para las diferentes versiones de Android 4.3.
Desconozco si para la 4.4 kitkat existe alguno pero independientemente de la versión os recomiendo ir probandolos (Hay que ser root excepto para reinstalacion de firmware por Odin) ya que a algunos les he funcionado.
Si mal no recuerdo y lo tendría que revisar, puse un posible solución que encontre por la Red en varios pasos a la hora de reinstalar el firmware.
Si alguno lo prueba puede darnos su opinión, ya que vuelvo a insistir en que todos los problemas del wifi no aparecen asi de la nada (pudiendo ser una averia), sino trás una actualización. Por lo tanto ahí está el problema, en algún archivo corrupto o una mala instalación.
Saludos.

Inteligente es aquel que sabe a dónde quiere ir y más inteligente aún es el que sabe a donde ya no tiene que volver!!!!.
Cada minuto que te enfadas pierdes 60 segundos de felicidad..... Por lo tanto sonrie que eso les jode. 😁

  • Posts del Foro: 2

05-may-2015 14:08:20 vía Web

Pedro Melo

Fernando Conde

Julián Suárez Mora

Amigos saludos. Les comento que después de horas de buscar la solución a este problema este post fue mi salvación; los problemas eran similares tanto en 4.3 como en 4.4 la recepción del wifi era nula (se quedaba colgando en activando y nunca activaba) restauré datos de fabrica y nada, estaba por probar cambiando los modems del teléfono hasta que me encontré con lo mencionado. Doy fe de que este post sirve y para aquellos que posean este problema prueben con esta solución primero con eso si no les favorece siguen con las otras.

Reitero los pasos tomados de este post:

1->>S4 con root >>
2->>instalar root explorer >>
3->>con root explorer abrir "system/build.prop" con el editor de texto)
4->buscar la linea: ro.securestorage.support=true cambiarla por: ro.securestorage.support=false
5 guarden
6 reinicien el celular*

i9505 4.4.2 kitkat wifi solucionado!!

Sigan los pasos al pie de la letra y comprueben que efectivamente los cambios se hayan realizado. Gracias por la solución y saludos desde Bogotá....:D:D

amigo no sabes si este proceso tambien es para el i9500? tengo el mismo problema y estoy desesperado ya. quisiera saber si el procedimiento es tambien para mi modelo. saludos desde El Salvador.

Hola que tal, soy nuevo por este foro y quiero dejar mi comentario positivo sobre este paso que me ha funcionada para 2 galaxy s4 uno es el i337 y el otro es el m919 con este paso y agregando este a la vez http://www.androidpit.com/how-to-transform-your-galaxy-s4-into-an-s5 mis 2 galaxy ya andan bien del wifi

saludos!

Buenos Días amigo, realice lo que indico de: > > > 1->>S4 con root >>

2->>instalar root explorer >>
3->>con root explorer abrir "system/build.prop" con el editor de texto)
4->buscar la linea: ro.securestorage.support=true cambiarla por: ro.securestorage.support=false
5 guarden
6 reinicien el celular*

AHORA MI MOVIL ENCIENDE Y SE QUEDA EN EL LOGO GALAXY S4 y DE AHY NO PASA, NECESITO AYUDA URGENTE POR FAVOR.
YA LO WIPE Y LE INSTALE LA RUN Y NADA

  • Posts del Foro: 1.974

05-may-2015 14:46:00 vía Web

Creo que te va a tocar instalar una rom stock de forma manual a través de Odin. Normalmente no debería pasar nada, pero esas cosas pueden pasar si tocamos la build.prop y hacemos algo que no es debido o no hacemos bien un procedimiento.

No seas egoísta y comparte tus conocimientos Android.
:D

  • Posts del Foro: 2

05-may-2015 15:57:49 vía Web

ME PUEDE AYUDAR COMO HACER UNA ROM STOCK DE FORMA MANUAL? YO LO HE FLASHEADO POR ODIN VARIAS VECES Y PASA LA PRUEBA DE INSTALACION, PERO SIGUE IGUAL, GRACIAS

  • Posts del Foro: 1.974

05-may-2015 16:43:52 vía Web

Si ves que con la rom que estás probando no funciona, bájate otra de Sammobile para tu modelo,y le realizas los Wipes antes y después de flashear la rom por Odin. Prueba y nos comentas.

No seas egoísta y comparte tus conocimientos Android.
:D

  • Posts del Foro: 1

12-may-2015 20:33:16 vía Web

Giancarlo Crespo

funciono par mi sin instalar nada ; despues de probar todo:

1->>S4 con root >>
2->>instalar root explorer >>
3->>con root explorer abrir "system/build.prop" con el editor de texto)
4->buscar la linea: ro.securestorage.support=true cambiarla por: ro.securestorage.support=false

5 guarden
6 reinicien el celular

i9505 4.4.2 kitkat wifi solucionado!!

HOLA PERDON PERO PODRIAS DETALLAR MAS EL PROCESO YA QUE TENGO EL MISMO PROBLEMA MI WI FI Y MI BLUETOOTH NO SE ACTIVA YA TENGO LA VERSION DE 5.0.2 DE ANDROIR LILLIPOP PERO NO FUNCIONA NADA DE LO QUE HE INTENTADO

  • Posts del Foro: 1

22-may-2015 10:10:51 vía Web

pero señor amigo por el amor de Dios mire bien la pregunta del joven el dice que busca la solucion del wifi para un s4 i9500 y usted le da ivitacion para la solucion del su problema y dice que no se ase responsable , pero por lo menos no lo desoriente porque se busca ayuda del wifi de un i9500 y no de un i9505 hay usted es el culpable por que dice unicamente para i9505 no se contradiga papa aprenda a leer mijo , tambien que no seas responsable pero tanpoco lo desoriente señor mire bien se pide ayuda para problema de i9500 noooo i9505 la ayuda la nesecita usted comprese unos lestes con telescopio pak vea hasta marter y jupiter y asi no se equivoque la proxima vez y no aga perder el tiempoo ala gente bye . desorientador de la comunidad

  • Posts del Foro: 1

31-may-2015 6:18:10 vía Web

Pablindc

Mauri Giunta

Pablindc

Mauri Giunta

Otra de la solucion de algunos usuarios fué ésta: (copio y pego tal cual está escrito)

1-descarga Root Explorer.apk a la PC, luego pasas el archivo a tu Tel via USB y lo instalas en el S4
2- en el root explores vas a Data/misc/ Wifi o a System/etc/Wifi (depende el modelo)
3-eliminas el archivo wpa_supplicant.conf
4-reinicias tu tel y Uala!!! tu S4 funcionando full, sin hacer Wipes,ni restauración de fabrica, ni nada muy avanzado.

Pero claro volvemos a lo mismo y es que deberás ser root para poder acceder a esas carpetas.
Antes te comenté que no porque hablaba de memoria, pero si que será necesario que seas root.
Y sino podrías probar a REINSTALAR el firmware con Odin y empezar de cero y limpiamente.

Tengo el mismo problema que el Wifi no se activa en el I9500. Se queda en color verde opaco. Con respecto a este método tengo una consulta: En mi dispositivo tengo el archivo "wpa_supplicant.conf" en las dos direcciones que indicaron ("Data/misc/ Wifi o a System/etc/Wifi (depende el modelo"). En cual de las dos tengo que hacer el borrado del archivo?
Agradezco su respuesta.

Yo nunca usé ese metodo porque para mi con la 4.3 bastó sólo con un wifi fix pero comprobando lo que dices yo tengo un 9505 y es cierto que aparece el mismo archivo a borrar en las 2 rutas.
Yo he abierto los 2 archivos y en la ruta Data/misc/wifi el archivo guarda los datos de todas las redes wifi a las que me he conectado para asi volverse a conectar automáticamente y reconocerlas.
En la otra ruta System/etc/wifi al abrir el archivo me encuentro con datos tecnicos y palabras como "device name samsung manufactured" y cosas demasiado técnicas.
Mi conclusión es que si como alguna vez se ha comentado la causa de que no se conecte a un wifi es por el archivo se ha corrompido trás una actualización y esas claves crean conflicto..... deberias borrar el archivo donde se guardan las contraseñas.
Pero ojo que es mi opinión y no soy un experto ni te aseguro nada.
Pienso que borrar un archivo donde se guardan las contraseñas no debe ser perjudicial ni estropearte nada.
Hay gente que haciéndolo le ha funcionado el wifi de nuevo.

Saludosl foristas, les comento mi historia: En mi S4 I9500 se me quedaba en gris el botón de Wifi y el Bluetooth, decía activando pero nunca se lograba activar. Le puse un montón de ROMs, de varios países, a la final me quedé con la de Rusia. Hice de todo borrando los archivos que indican en el foro (siendo root), incluso cambiando en un archivo la palabra "true" a "false" y nada. Incluso lo llevé a dos servicios técnicos que hicieron de todo y nada, me estaba dando por vencido hasta que me resultó algo que se los voy a detallar.

En youtube encontré este video:

Galaxy s4 wifi issue grey wifi fix 100% guarantee (lo buscan tal como está)

En este video pueden ver que la persona que lo hace, primero es un equipo roto el display, y segundo lo tienen que desarmar una parte.

Yo lo hice tal como indicó el video y nada.....

Ya me sentaba a llorar, pero lo que hice fue....prendido el equipo le saqué toda la carcasa y comencé a aplastar donde se conectan los flex, puerto de tarjeta sim, y comencé a aplastar poco a poco los componentes (ojo no sé si se podrá hacer eso pero yo lo hice). Así pasé si quiera unos 5 minutos tratando de ver si había algo flojo y así pasaron los cinco minutos (todo esto sin dejar que se apague el equipo). Pasado este tiempo vi que en la pantalla se me prendió automáticamente el bluetooth, cosa que me dio una esperanza. Aplasté el botón del wifi y seguía en gris, hasta que un minuto después automáticamente se activo y me detectó redes wifi.

Soy nuevo en temas de android, pero me ha tocado aprender muchísimo sobre estos temas ya que no quería perder mi equipo sin darle una solución. Voy a probarlo por varios días y si me resulta algún problema (espero que no sea así) yo les comento.

Gracias a todos por sus aportes.

Pablindc

Esto si funciona de verdad.
Vean el video se llama

Galaxy s4 wifi issue grey wifi fix 100% worked

Búsquenlo en youtube, aunque en el video se ve poco profesional lo que hace la persona, si funciona.
Les recomiendo que quiten los tornillos y quiten la tapa, vean videos de como desmontar el teléfono. Tienen que quedar la placa base a la vista, luego van a buscar un cable negro y uno largo que se encuentran a la altura del botón de encendido. En mi caso yo despegue los dos los ajuste y encendí el teléfono y efectivamente reconoció las wifi, claro con poca señal porque cuando tu pegas el plástico esta actúa de alguna forma de amplificador de señal. después cuando ajusten nuevamente los tornillos no aprieten tanto para que no corte la señal nuevamente.

Porque sucede esto:

Todo radica en el mal ensamblaje del teléfono. El cable queda muy ajustado este al estar muy apretado se corta la señal. Porque sucede esto.
Bueno como muchos sabrán cuando un procesador trabaja mucho se calienta, esto ocurre cuando cambias de versión de ROM de una liviana a una más avanzada que le va exigir más al procesador y esto causa que el teléfono se caliente y el plástico se expanda, trayendo como consecuencia que el cable se apriete y la señal se vea afectada, claro a algunas personas le funciona lo de cambiar de ROM porque le montan una más liviana la cual no le exija tanto al procesador y no se caliente tanto.
Si de verdad quieren solucionar esto hagan la prueba de ajustar bien ese cable y no apretar tanto los tornillos de esa zona. Se los digo pase una semana montando ROM tanto custom como de stock, flasheando el teléfono una y otra vez, wipeando, montando modem, y las soluciones que acá dan de modificar unos archivos mediante el root explorer, no subestimo ninguna de esas opciones, pero no me había funcionado ninguna, salvo la que les estoy dando. Ojo para desarmar mucho cuidado vean un video de cómo hacerlo paso a paso en youtube hay muchos y bien detallados. Claro si tienes garantía del teléfono mejor llévalo al servicio sino, experimenta tu mismo y con paciencia lo lograras.

Suerte.:D(cool)

  • Posts del Foro: 1

01-jun-2015 2:33:56 vía Web

Hola buenas noches, tengo problemas con el Wifi desde hace una semana par acá, no se si tiene que ver con que lo empecé a cargar con otro cargador diferente a samsung debido a que perdí el cargador. Desde que cargué mi teléfono con otro cargador empecé a presentar problemas con el Wifi de mi cel.

Mi versión es 5.0.1 I9505XXUHOE1, el wifi enciende color claro pero cuando quiere enciende normal, cuando el teléfono se apaga empieza a presentar el problema nuevamente.

NO se que hacer

  • Posts del Foro: 2

04-jun-2015 16:51:07 vía Web

Perdon, respecto de las observaciones que nos hace el compañero "Cesar R" lo cual me parece muy interesante, quisiera consultarle.. A que se refiere con Cables?? Dado que la antena Wifi esta dentro de la carcasa media en un circuito impreso dentro del plastico.. No pregunto por criticar sino para saber cual es la zona a descongestionar. La antena Wifi esta ubicada mirando el telefono de espaldas, sobre el borde superior izquierdo.. Gracias por la ayuda!

  • Posts del Foro: 2

04-jun-2015 16:53:07 vía Web

Cesar R

Pablindc

Mauri Giunta

Pablindc

Mauri Giunta

Otra de la solucion de algunos usuarios fué ésta: (copio y pego tal cual está escrito)

1-descarga Root Explorer.apk a la PC, luego pasas el archivo a tu Tel via USB y lo instalas en el S4
2- en el root explores vas a Data/misc/ Wifi o a System/etc/Wifi (depende el modelo)
3-eliminas el archivo wpa_supplicant.conf
4-reinicias tu tel y Uala!!! tu S4 funcionando full, sin hacer Wipes,ni restauración de fabrica, ni nada muy avanzado.

Pero claro volvemos a lo mismo y es que deberás ser root para poder acceder a esas carpetas.
Antes te comenté que no porque hablaba de memoria, pero si que será necesario que seas root.
Y sino podrías probar a REINSTALAR el firmware con Odin y empezar de cero y limpiamente.

Tengo el mismo problema que el Wifi no se activa en el I9500. Se queda en color verde opaco. Con respecto a este método tengo una consulta: En mi dispositivo tengo el archivo "wpa_supplicant.conf" en las dos direcciones que indicaron ("Data/misc/ Wifi o a System/etc/Wifi (depende el modelo"). En cual de las dos tengo que hacer el borrado del archivo?
Agradezco su respuesta.

Yo nunca usé ese metodo porque para mi con la 4.3 bastó sólo con un wifi fix pero comprobando lo que dices yo tengo un 9505 y es cierto que aparece el mismo archivo a borrar en las 2 rutas.
Yo he abierto los 2 archivos y en la ruta Data/misc/wifi el archivo guarda los datos de todas las redes wifi a las que me he conectado para asi volverse a conectar automáticamente y reconocerlas.
En la otra ruta System/etc/wifi al abrir el archivo me encuentro con datos tecnicos y palabras como "device name samsung manufactured" y cosas demasiado técnicas.
Mi conclusión es que si como alguna vez se ha comentado la causa de que no se conecte a un wifi es por el archivo se ha corrompido trás una actualización y esas claves crean conflicto..... deberias borrar el archivo donde se guardan las contraseñas.
Pero ojo que es mi opinión y no soy un experto ni te aseguro nada.
Pienso que borrar un archivo donde se guardan las contraseñas no debe ser perjudicial ni estropearte nada.
Hay gente que haciéndolo le ha funcionado el wifi de nuevo.

Saludosl foristas, les comento mi historia: En mi S4 I9500 se me quedaba en gris el botón de Wifi y el Bluetooth, decía activando pero nunca se lograba activar. Le puse un montón de ROMs, de varios países, a la final me quedé con la de Rusia. Hice de todo borrando los archivos que indican en el foro (siendo root), incluso cambiando en un archivo la palabra "true" a "false" y nada. Incluso lo llevé a dos servicios técnicos que hicieron de todo y nada, me estaba dando por vencido hasta que me resultó algo que se los voy a detallar.

En youtube encontré este video:

Galaxy s4 wifi issue grey wifi fix 100% guarantee (lo buscan tal como está)

En este video pueden ver que la persona que lo hace, primero es un equipo roto el display, y segundo lo tienen que desarmar una parte.

Yo lo hice tal como indicó el video y nada.....

Ya me sentaba a llorar, pero lo que hice fue....prendido el equipo le saqué toda la carcasa y comencé a aplastar donde se conectan los flex, puerto de tarjeta sim, y comencé a aplastar poco a poco los componentes (ojo no sé si se podrá hacer eso pero yo lo hice). Así pasé si quiera unos 5 minutos tratando de ver si había algo flojo y así pasaron los cinco minutos (todo esto sin dejar que se apague el equipo). Pasado este tiempo vi que en la pantalla se me prendió automáticamente el bluetooth, cosa que me dio una esperanza. Aplasté el botón del wifi y seguía en gris, hasta que un minuto después automáticamente se activo y me detectó redes wifi.

Soy nuevo en temas de android, pero me ha tocado aprender muchísimo sobre estos temas ya que no quería perder mi equipo sin darle una solución. Voy a probarlo por varios días y si me resulta algún problema (espero que no sea así) yo les comento.

Gracias a todos por sus aportes.

Pablindc

Esto si funciona de verdad.
Vean el video se llama

Galaxy s4 wifi issue grey wifi fix 100% worked

Búsquenlo en youtube, aunque en el video se ve poco profesional lo que hace la persona, si funciona.
Les recomiendo que quiten los tornillos y quiten la tapa, vean videos de como desmontar el teléfono. Tienen que quedar la placa base a la vista, luego van a buscar un cable negro y uno largo que se encuentran a la altura del botón de encendido. En mi caso yo despegue los dos los ajuste y encendí el teléfono y efectivamente reconoció las wifi, claro con poca señal porque cuando tu pegas el plástico esta actúa de alguna forma de amplificador de señal. después cuando ajusten nuevamente los tornillos no aprieten tanto para que no corte la señal nuevamente.

Porque sucede esto:

Todo radica en el mal ensamblaje del teléfono. El cable queda muy ajustado este al estar muy apretado se corta la señal. Porque sucede esto.
Bueno como muchos sabrán cuando un procesador trabaja mucho se calienta, esto ocurre cuando cambias de versión de ROM de una liviana a una más avanzada que le va exigir más al procesador y esto causa que el teléfono se caliente y el plástico se expanda, trayendo como consecuencia que el cable se apriete y la señal se vea afectada, claro a algunas personas le funciona lo de cambiar de ROM porque le montan una más liviana la cual no le exija tanto al procesador y no se caliente tanto.
Si de verdad quieren solucionar esto hagan la prueba de ajustar bien ese cable y no apretar tanto los tornillos de esa zona. Se los digo pase una semana montando ROM tanto custom como de stock, flasheando el teléfono una y otra vez, wipeando, montando modem, y las soluciones que acá dan de modificar unos archivos mediante el root explorer, no subestimo ninguna de esas opciones, pero no me había funcionado ninguna, salvo la que les estoy dando. Ojo para desarmar mucho cuidado vean un video de cómo hacerlo paso a paso en youtube hay muchos y bien detallados. Claro si tienes garantía del teléfono mejor llévalo al servicio sino, experimenta tu mismo y con paciencia lo lograras.

Suerte.:D(cool)

Perdon, respecto de las observaciones que nos hace el compañero "Cesar R" lo cual me parece muy interesante, quisiera consultarle.. A que se refiere con Cables?? Dado que la antena Wifi esta dentro de la carcasa media en un circuito impreso dentro del plastico.. No pregunto por criticar sino para saber cual es la zona a descongestionar. La antena Wifi esta ubicada mirando el telefono de espaldas, sobre el borde superior izquierdo.. Gracias por la ayuda!

  • Posts del Foro: 2

13-jun-2015 19:43:49 vía Web

Hola Mauri,he leido varios post tuyos sobre como arreglar el Wifi y Bluetooth,pero necesito que me ayudes personalmente.Hace unos dias actualize la ultima version Lollipop de mi S4 GT-19506 .android 5.0.1.Desde entonces no se me activa el wifi,me gustaria que me ayudases a solucionar mi problema ya que en unos dias me voy de viaje a Londres y alli utilizare la red wifi.Pero mi problema es que no se me activa,me sale "Activando..." pero nunca se activa.He llegado a formatear el movil porque le mande un mensaje a Samsung y me conbtestaron eso,pero nada.Si me pudieses ayudar te lo agradeceria muchisimo ya que se me han acabado los datos del movil y no puedo utilizar muchas aplicaciones.Muchas gracias,espero una respuesta que me pueda ayudar :)

  • Posts del Foro: 2

13-jun-2015 20:12:40 vía Web

Buenas, en mi S4 GT-19506 ANDROID 5.0.1,despues de actualizar la ultima version de Lollipop el wifi y el bluetooth no se me activa,he llegado a ponerlo de fabrica,pero nada,necsito ayuda.Gracias.

  • Posts del Foro: 2.492

15-jun-2015 23:01:02 vía App

Hola Sandra.Siento no haber podido contestarte antes pero ando con temas personales y no puedo dedicar al foro todo el tiempo que me gustaría pero volveré con fuerzas.jejeje.
A ver,respecto a tu tema en cuestión y confirmando ya que todos tus problemas han aparecido trás actualizar,y viendo también que reseteando a modo fábrica sigues igual yo haría el mismo proceso pero con ODIN que es un programa para instalar "cosas" en Samsung.
1-Deberias meterte en la web de Sammobile y descargar alli la rom para tu modelo exacto de S4.
2- Enciende tu movil en modo recovery y haz el wipe cache y wipe factory reset.
3-Enciende tu movil en modo Download e instala la rom de Sammobile que te has debido descargar antes.
4-Una vez instalada vuelve a hacerle el wipe cache y wipe factory.
5- Por ultimo vuelve a reinstalar rom y pruebas a ver si se solucionó tu problema.

Se que es un poco coñazo pero como digo post mas arriba creo que a todos nos ha quedado claro que los problemas del S4 y el wifi vienen trás una actualización y debe ser algo que se queda de la anterior que crea conflictos y de ahí el hacerlo asi para BORRAR cualquier rastro y empezar de cero.
Otras ideas asi en plan rapido no se me ocurren aparte de hacerte ROOT e intentar las diversas soluciones que se dicen más arriba.
Suerte y nos cuentas.

Inteligente es aquel que sabe a dónde quiere ir y más inteligente aún es el que sabe a donde ya no tiene que volver!!!!.
Cada minuto que te enfadas pierdes 60 segundos de felicidad..... Por lo tanto sonrie que eso les jode. 😁