Aplicacion Webview simplemente se cae

  • Respuestas:0
  • AbiertoSin chinchetaSin solución
  • Posts del Foro: 1

08-ago-2014 20:37:25 vía Web

Hola

Tengo el siguiente problema, hice una app super sencilla lo único que tiene que hacer es mostrar un sitio web, para un pendrive WT-801, la cuestion q la aplicación corre sin problemas pero derrepente se cae, pero vez que esta, pero continua funcionando al pinchar el boton para ver las aplicaciones que estan corriendo aparece

Esto es relativo a veces se cae a la media hora otras veces a als dos horas, la gracia que tiene que ir conectado a un televisor y mostrar info por tanto tiene que estar prendida todo el dia

El codigo es solo este en el onCreate (el sitio es https)

protected void onCreate(Bundle savedInstanceState) {
super.onCreate(savedInstanceState);

    //eliminamos el top bar de la aplicacion
    this.requestWindowFeature(Window.FEATURE_NO_TITLE);
    this.getWindow().setFlags(WindowManager.LayoutParams.FLAG_FULLSCREEN, WindowManager.LayoutParams.FLAG_FULLSCREEN);      

    //seteamos el layout con el webview
    setContentView(R.layout.activity_main);

          webView = (WebView) findViewById(R.id.webView1);
          webView.reload();
         webView.setWebViewClient(new WebViewClient());                         
        webView .getSettings().setJavaScriptEnabled(true);
        webView .getSettings().setDomStorageEnabled(true);              
         webView.getSettings().setJavaScriptEnabled(true);
          webView.loadUrl("la url");
          webView.setWebViewClient(mWebClient);

}

private final WebViewClient mWebClient = new WebViewClient() {

    @Override
    public boolean shouldOverrideUrlLoading(WebView view, String url) {
        view.loadUrl(url);
        return true;
    }

    @Override
    public void onReceivedSslError(WebView view, SslErrorHandler handler,
        SslError error) {
        handler.proceed();
        }
};

El layout es el siguiente

android:id="@+id/webView1"
android:layout_width="fill_parent"
android:layout_height="fill_parent"

Ya no se si es el código o el aparato se le termina la memoria he probado eliminando la ram y el cache mediante clean cache y programandolo, pero de todas maneras llega un momento que se cae

gracias