Samsung Galaxy S4 — Reparacion Wifi S4 instalando modem en Android 4.3

  • Respuestas:395
  • AbiertoMarcado con chinchetaSin solución
  • Posts del Foro: 4

20-ene-2015 4:24:29 vía Web

hola buenas noches mi s4 es root con lollipop 5.0 esa linea no aparece en el lugar indicado.. veo muchas ro. pero esa no.. a mi me funciona todo menos el 4G que me habia funcionado bien hace un año hasta que decidi jugar con mi aparato.. hoy ando bajando el fireware desde sammobile a ver si recupero el 4g

  • Posts del Foro: 3

23-ene-2015 18:37:57 vía Web

Ayuda amigo instale rom de luxes en mi s4 i9515 pero no enciende mi wifi no tengo el mudulo y peor lo busco y no encuentro ayudame pana la banda base es I9515LUBU1ANH2

  • Posts del Foro: 3

23-ene-2015 18:50:39 vía Web

Ayuda amigo instale rom de luxes en mi s4 i9515 pero no enciende mi wifi no tengo el mudulo y peor lo busco y no encuentro ayudame pana la banda base es I9515LUBU1ANH2

  • Posts del Foro: 2

24-ene-2015 10:52:28 vía Web

que tal gente me presento soy edu de argentina espero que anden bien, bueno vamos al grano tengo el mismo problema que todos, tengo un s4 gt-i9295 (active) tenia el firmware I9295XXUBML3 4.2.2 , actualize a I9295XXUCNE5 4.4.2 y al mes empezo el problema tanto como el wifi y el bluetooh quedan en "ACTIVANDO" y no pasa de ahi eh probado muchas cosas ejemplo ( tal vez le sirva a alguno)

1) instalando stock rom (firmware original)
instalar cwm - desde cwm instalar UPDATE-SuperSU-v2.40
reiniciar el celular. entrar a la app supersu desactivar knox
volver a reiniciar el celular - instalar root explorer y dirigirse
a la carpeta : raiz / data / misc / wifi (les va pedir permiso super usuario, aceptan)
renombren o borren el archivo " wpa_supplicant.conf"
reinicien el celular manualmente y cuando este apagado sacarle la bateria por 3 min

ejemplo 2:

2) poniendo el codigo *#0011#
entrar en ajustes de wifi y desactivar el ahorro de energia del wifi y reiniciar celular

3) eh intentado la mayoria de las soluciones posteadas aca con soluciones pasajeras

Teoria :

nose por que razon soluciones que han servido anteriormente no vuelven a servir por segunda vez ( es como que se inmunizara por decirlo asi) me llama la atencion todo esto yo supongo que es un error del sistema con el enraizamiento wifi /bluetooh al actualizar o rootear , tal vez el sistema de archivos se escribió incorrectamente, corrompiendo la ruta (creando un problema de asociación) haciendo que el gestor de arranque no lo pueda cargar correctamente , digo esto por que hay ocasiones (muy rara vez) que apagando y prendiendo manualmente muchas veces vuelven a funcionar (por poco tiempo)

Supuestas Soluciones:

Navegando por internet encontre lo que parece ser... una solucion o una explicacion de por que pasa esto, voy a poner un fragmento( en ingles) con la esperanza de que alguien que sepa de este sistema o android arroje un poco de luz a partir de esta informacion que voy a dejar :

"3. Provide a proper wpa_supplicant.conf for your device
Providing a wpa_supplicant.conf it's important because the control
socket for android is specified in this file (ctrl_interface= ). This file
should be copied by your AndroidBoard.mk to
$(TARGET_OUT_ETC)/wifi (usually
/system/etc/wifi/wpa_supplicant.conf ). This location will be used
on wpa_supplicant service from init.rc.
There are two different ways in which wpa_supplicant can be
configured, one is to use a "private" socket in android namespace,
created by socket_local_client_connect() function in wpa_ctrl.c
and another is by using a standard unix socket.

Minimum required config options in wpa_supplicant.conf :
- Android private socket

ctrl_interface=wlan0
update_config=1

  • Unix standard socket

    5ctrl_interface=DIR=/data/system/wpa_supplicant GROUP=wifi
    update_config=1

    Depending on your driver you might also want to add:
    ap_scan=1

    If you have AP association problems with should change to
    ap_scan=0 to let the driver do the association instead of
    wpa_supplicant.
    Seems that you can add ap_scan=1 to your wpa_supplicant.conf
    depending on the drivers you have.

    After some more research on the subject of ap_scan i found that:

    AP scanning/selection

    By default, wpa_supplicant requests driver to perform AP

    scanning and then

    uses the scan results to select a suitable AP. Another alternative

    is to

    allow the driver to take care of AP scanning and selection and

    use

    wpa_supplicant just to process EAPOL frames based on IEEE

    802.11 association

    information from the driver.

    1: wpa_supplicant initiates scanning and AP selection

    0: driver takes care of scanning, AP selection, and IEEE 802.11

    association

    parameters (e.g., WPA IE generation); this mode can also be

    used with

    non-WPA drivers when using IEEE 802.1X mode; do not try to

    associate with

    APs (i.e., external program needs to control association). This

    mode must

    also be used when using wired Ethernet drivers.

    2: like 0, but associate with APs using security policy and SSID

    (but not

    BSSID); this can be used, e.g., with ndiswrapper and NDIS

    driver to

    enable operation with hidden SSIDs and optimized roaming; in

    this mode,

    only the first network block in the configuration file is used and

    this

    configuration should have explicit security policy (i.e., only one

    option

    in the lists) for key_mgmt, pairwise, group, proto variables

    It seems that addind ap_scan=1 imposes that
    wpa_supplicant.conf handles the scanning and AP selection. IF
    there's something wrong with the driver, and not with
    wpa_supplicant as i originaly thought, this could bypass the
    problem.
    So I added ap_scan=1 just before the device identification lines in
    wpa_supplicant.conf, reeboted, and now the wifi and bluetooth
    toggle normaly. I've tried ap_scan=0 (the driver handles the
    scanning) and the problem returns, so ap_scan=1 does allow you
    to toggle the wifi and BT on."

Preguntas:

1- habra algun wifi fix para mi celular como el de este video de youtube "How to Fix Problems Android Wifi - Samsung Galaxy S4 - All Samsung phones [HD]" ?
2- me podrian pasar el link de un stock recovery para mi modelo de celular? ( es para eliminar los binarios del root y el cwm )
3- como puedo saber cual es el firmware indicado para mi( el celular me lo trajieron de USA y vino con el firmware I9295XXUBML3 4.2.2 y lo actualize a I9295XXUCNE5 4.4.2 ) ?
4- eh escuchado el termino "hacerle el sistema desde 0" saben de algo asi (que no sean los wipe)?
5- algun soft reset?

  • Posts del Foro: 1

25-ene-2015 21:30:10 vía Web

mauri una pregunta mira yo tengo el s4 model sgh-I337M version 4.4.2 version de banda I337MUMAMB2
bueno el problema con mi celular es este no me encinde el wifi ni el bluetooth derrepente se me va la señal cuando eso pasa lo reinicio y aveces me prende el wifi y el bluetooth pero cuando lo bloqueo asi cuando no lo utilizo, lo rato de desbloquear y hace como si no sirviera el touch y se pone loco se traba derrepente se reinicia solo y ya todo normal como si nada y no me prende otra vez el wifi ni el bluetooth lo desarme y y limpie y me jalo pero volvio a hacer lo mismo alos 30 min o 5 horas de uso ya lo formatie no se cuantas veces y no me dicen que la cargue un andriod mas viejito uno abajo pero no se que me recomiendas tu recuerda mi s4 no es como el tuyo y no puedo instalarle el wififix que tu le pusiste o si? m numero de telefono es 7681044004 soy de mexico tengo what te agradeceria mucho tu ayuda mi buen gracias saludos
pd la clave es +521

  • Posts del Foro: 2.486

25-ene-2015 22:07:12 vía App

Mi consejo es que intentes instalar desde cero la ultima version que tienes, la 4.4.2 que sea para tu modelo de S4.Con el programa Odin.
No intentes bajar a una 4.3 o inferior porque el bootloader o arranque es diferente y el movil no te pasará de la pantalla de samsung.
Mira en Sammobile que alli tienen publicadas todas las roms.

Inteligente es aquel que sabe a dónde quiere ir y más inteligente aún es el que sabe a donde ya no tiene que volver!!!!.
Cada minuto que te enfadas pierdes 60 segundos de felicidad..... Por lo tanto sonrie que eso les jode. 😁

  • Posts del Foro: 2

26-ene-2015 18:07:58 vía Web

mauri podras por favor contestar lo que te pregunte mas arriba

  • Posts del Foro: 2.486

26-ene-2015 23:04:50 vía App

Hola Edu:
Lo mejor que puedes hacer o intentar es instalar como dices desde cero una rom stock para tu modelo exacto de S4.
Busca en la web de Sammobile que seguro que alguno tienes.
Que sea la misma version que tienes 4.4.2 o si existiese superior.De esa forma eliminarás el root y el recovery modificado que tienes.
Sobre un wifi fix siento no poder ayudarte.
La verdad es que la opciones que has probado son las que se barajan por el foro y ninguna es buena al 100% ni mala ya que a algunas personas les ha funcionado.
De echo post más arriba escribí una recomendación que encontré trás mucho leer y leer y que yo sepa nadie se ha pronunciado al respecto sobre si funciona o no.Me refiero a hacer los wipes antes y después de la instalación.
Son 3 pasos. Mas arriba está descrito.
Podrias probarlo y nos cuentas.
Un saludo.

— modificado el 26-ene-2015 23:07:52

Inteligente es aquel que sabe a dónde quiere ir y más inteligente aún es el que sabe a donde ya no tiene que volver!!!!.
Cada minuto que te enfadas pierdes 60 segundos de felicidad..... Por lo tanto sonrie que eso les jode. 😁

  • Posts del Foro: 1

01-feb-2015 5:05:57 vía Web

Buenas noches PABLO como estás? basándonos en esa explicación se puede hacer lo mismo para reparar que el celular no reconozca la red de la operadora?

  • Posts del Foro: 4

03-feb-2015 18:57:42 vía Web

Buen dia saludos .......soy de Venezuela y tengo un s4 con el mismo problema del wifi que se queda "activando"..... he leido todos los comentarios de todos los foristas y las posibles soluciones y realmente he quedado como si me hablaran en chino porque no entiendo como hacer nada.......de acuerdo a todo lo que he leido he visto que la solucion que coloco el forista Giancarlos Crespo es la que mayormente ha funcionado y quisiera realmente probarla...... pero como les digo no se casi nada de esto y quisiera que me ayudaran a ver como hago para rootear el telefono, asi como tambien me pudieran ayudar explicando un poco mejor los otros pasos a seguir.... a continuacion les coloco una imagen con los datos de mi telefono: (AGRADECIENDOLES CON EL ALMA ME PUEDAN AYUDAR)
image

  • Posts del Foro: 1

09-feb-2015 18:14:26 vía Web

Hola disculpa amig n puedo conectarme a wifi porq teng un s4 pero n le da es gt 1900 el normal me puedes decir com se hace

  • Posts del Foro: 2

10-feb-2015 1:09:02 vía Web

hola muy buenas a todos alguienq me ayude por dios, tengo el mismo problema en mi lg l4 noenciende el wifi, busque modificar esa parte pero no la encuentro, quizas sea distinto al samsung por favor alguien me puede dar una mano, muchas gracias

  • Posts del Foro: 1

17-feb-2015 0:59:29 vía Web

Hola, no aparece la version del Wifi fix para mi telefono, tengo el I9505VJUGNE2. Que puedo hacer?

  • Posts del Foro: 2.486

18-feb-2015 9:32:10 vía App

Christian Torruella

Hola, no aparece la version del Wifi fix para mi telefono, tengo el I9505VJUGNE2. Que puedo hacer?

Según tu firmware tienes 4.4.2 kitkat y esos fix eran en su dia para la 4.3
Sobre ¿Que puedes hacer?.
Es complicado porque nadie sabe la solución correcta al 100% para arreglar el problema y las posibles soluciones están ya por el post.
Es bueno (y va para todos el mensaje subliminal) que comenteis como os ha pasado lo del wifi, desde cuando, si algo habeis tocado o actualizado y que posibles soluciones habeis tomado antes de daros por vencidos porque sino estamos un poquito a ciegas.
La solución más sencilla en tu caso sería volver a reinstalar la ultima 4.4.2 para tu modelo en Sammobile por si se pudiese corregir el problema.

Inteligente es aquel que sabe a dónde quiere ir y más inteligente aún es el que sabe a donde ya no tiene que volver!!!!.
Cada minuto que te enfadas pierdes 60 segundos de felicidad..... Por lo tanto sonrie que eso les jode. 😁

  • Posts del Foro: 1

21-feb-2015 0:10:22 vía Web

Hola a todos, como muchos tengo el problema de el wifi desactivado en mi Galaxy S4 el cual por cierto ya no estoy seguro si el modelo es el SGH-I337M o el SGH-M919V ya que inicial mente cundo verifique el modelo en el apartado de configuracion\acerca del telefono: me decia "SGH-I337M" y al retirar la bateria en la etiqueta dice " SGH-M919V".

Aclaro que el movil lo compre de segunda mano y le puse el chip de mi telefono que tenia en plan tarifario.

Mi problema empeso al ir a TELCEL (Mexico) a cancelar mi plan ya que acababa plazo forzoso de 24 meses y queria conservar el equipo en prepago. Posterior a hacer dicho tramite el equipo dejo de reconocer la red no podia hacer ni recibir llamadas y lo que son las cosas el wifi andaba perfectamente. Despues de hacer el reclamo correspondiente con la operadora TELCEL se limitaron a decirme que por parte de ellos todo estaba correcto y que si habia un problema era con el equipo y que si yo lo deseaba dejar el equipo a servicio tecnico para que me hicieran un presupuesto de la reparacion. Yo molesto con la respuesta y actitud de TELCEL lleve mi telefono a un tiaguis de computacion y telefonia y ahi me recomendaron a una persona que me lo podria arreglar.

Ya al revisarlo literalmente me dijo que mi telefono lo habia desmadrado los mismos de TELCEL y que mi IMEI estaba en 00000000000 y me cobro el equivalente a $30 Dlls por reprogramarmelo y efectivamente logro hacer que reconociera la red de telefonia, pero o sorpresa que cuando quise accesar a la wifi de mi casa el wifi nunca se activo, se lo volvi a llevar a la misma persona y cuando regrese por el me dijo que ya todo estaba correcto y que hasta el android me habia actualizado de 4.3 a 4.4.2 verifique y efectivamente wifi activado (en verde) y reconocia las diferenres redes inalambricas que habia al rededor.

Llego a casa muy feliz configuro mi wifi y todo bien, al siguiente dia quiero agregar la wifi de mi lugar de trabajo y "sasssss " el wifi se desactiva y solo se queda la pantalla con la palabra Activando... y pues claro que nunca, hablo con el que disque me lo reparo y me dice que lo que pasa es que tengo el base band dañado y hay que reinstalarlo pero que eso serian otros $20 Dlls y yo le digo, que que va a pasar cuando le pague otors $20 jale un rato y vuelva a lo mismo? y para no hacerla un mas larga pues me mando por un tubo.

Yo no soy experto en estos asuntos ni mucho menos pero pues la necesidad y me puse a leer post aqui y aya y empese a meterle mano llego el punto donde ya no cargo el cel y solo me salian 2 triangulitos amarillos, ya decidido a lograr que jalara o muriera en el intento mediante Kies logre hacer una recuperacion de firmware de emergencia el Kies me pidio el nombre del telefono y el numero de serie, puse los que venian detras de la bateria se hiso el proceso de recuperacion y Hooooo mi celular daba signos de vida (aunque dato curiso ya no salia el logo de TELCEL, sino el de NEXTEL ) y todo parecia funcionar configure la wifi de mi trabajo y todo fantastico pero cuando llegue a casa quiero agregar la wifi y de nuevo se desactiva:( .

Via Odin 3.09 e instalado un par de modems canadienses y lo mismo se instalan bien pero al querer agregar una nueva conexion wifi regresa el problema estoy a punto de convertir mi cel en un original porta vasos o ponerlo como suela de mi zapato.

Halguien que tubiese el mismo problema y haya dado con alguna solucion, sugerencias, ideas descabelladas, actos extremos, lo que sea se los agradecere.

Una disculpa por adelantado por haberme extendido en la explicacion del problema pero pues quise detallar lo mas que pudiera.

  • Posts del Foro: 1

26-feb-2015 21:35:58 vía Web

hola Mauri, tengo el Galaxy S4 9500, soy de Argentina y cuando pasó por una actualización se quedó sin wifi. Los service de la ciudad donde vivo son muuuuy precarios y me dicen que hay que cambiarle la placa, por eso recurro a tu opinión! gracias

  • Posts del Foro: 2.486

26-feb-2015 22:27:07 vía App

Lilian Camejo

hola Mauri, tengo el Galaxy S4 9500, soy de Argentina y cuando pasó por una actualización se quedó sin wifi. Los service de la ciudad donde vivo son muuuuy precarios y me dicen que hay que cambiarle la placa, por eso recurro a tu opinión! gracias

Hola Lilian: Asi a distancia no te puedo asegurar nada pero estoy casi seguro que tu movil 9500 no tiene ninguna avería en la placa ni nada parecido.Y es que está pasando tantas veces lo del problema del wifi trás una actualización....
Varias cositas:
¿Entiendes algo de Android?. Cosas como programa Odin, instalar firmwares, modo recovery y todo eso.
Es que es para saber como guiarte un poco por si alguna solución de éste post te pueda servir.
Ya es un post bastante largo pero te aconsejo que lo leas y vayas preguntando tus dudas.Por cierto ¿Sabes que versión de Android tenias y a cual se te actualizó? .

Inteligente es aquel que sabe a dónde quiere ir y más inteligente aún es el que sabe a donde ya no tiene que volver!!!!.
Cada minuto que te enfadas pierdes 60 segundos de felicidad..... Por lo tanto sonrie que eso les jode. 😁

  • Posts del Foro: 5

27-feb-2015 1:41:06 vía Web

a mi me pasa lo mismo ya instela rones de sanmobile intale una que dice de españa y españa version black

  • Posts del Foro: 1

05-mar-2015 13:44:13 vía Web

Buenas, una consulta. Haver, acavo de actualizar mi s4 con la version lollipop y no me deja usar el wifi, alguna sugerencia?
Gracias de antemano