Mensaje de advertencia al actualizar una app en google play console

  • Respuestas:0
  • AbiertoSin chinchetaSin solución
  • Posts del Foro: 1

13 may. 2017 14:44:54 vía Web

Hola,Buenos días.

Ayer intente de actualizar una aplicación y en google play console me salio en el apartado de versiones el siguiente mensaje:


Advertencia:

Actualiza al nuevo modelo de permisos
ADVERTENCIA
Los usuarios que tengan actualmente un APK con el código de versión 11, orientado al SDK 22 o a una versión anterior, podrán actualizar a este APK. Sin embargo, cuando lo hagan, no podrán actualizar a los APK orientados al SDK 22 o a una versión anterior.
SUGERENCIA
Si has hecho este cambio de forma intencionada, asegúrate de que las próximas actualizaciones para los usuarios que cambien a este APK estén dirigidas al SDK 23 o a una versión posterior.


Esta ultima actualización la he realizado desde Android Studio pero antes usaba eclipse.

En la versión anterior utilizaba
android:minSdkVersion="14" android:targetSdkVersion="19"

Nueva versión (Advertencia de google play)
android:minSdkVersion="14" android:targetSdkVersion="25"

Los permisos siempre han sido los mismos:

android.permission.INTERNET
android.permission.ACCESS_NETWORK_STATE
android.permission.ACCESS_WIFI_STATE

Creo que son normales y no peligrosos.

Segunda prueba de la nueva actualización si modifico el targetSdkVersion a 19 funciona como siempre he utilizado y no muestra ningún error.

Mis preguntas:
-Actualizo siempre las aplicaciones con el mismo sdkVersion original o puedo subir la versión?
-Si actualizo con el targetSdkVersion 25 (sale la advertencia), podría tener problemas si lo ignoro?
-Que tendría que hacer?
-Tengo que realizar algo en especial con los permisos que utilizo? o solo con declararlos en el manifest es suficiente?

Perdón por el mensaje pero estoy un poco perdido con este tema.

Muchas gracias y disculpen las molestias.

Contestar

Artículos recomendados